Utilisation des fonctions de LibreOffice Calc

Calcul de la moyenne d'une liste de valeurs

Cotes à comptabiliserUn étudiant souhaite pouvoir calculer automatiquement la moyenne de ses résultats d'évaluations en différentes branches. Il établit pour cela une feuille de calcul du type illustré ci-contre.

La moyenne doit être indiquée dans la cellule B5.

  • Dans un nouveau classeur, établis la feuille de calcul telle qu'elle est présentée ci-dessus ;
  • si ce n'est déjà fait, sélectionne la cellule B5 dans laquelle doit apparaître le résultat du calcul ;
  • frappe le signe = qui débute toute formule.

La liste des fonctions directement disponibles s'ouvre à la place de la zone d'adresse, à gauche de la barre de calculs.

Fonction moyenne
  • Ouvre la liste déroulante des fonctions directement disponibles ;
  • Sélectionne la fonction MOYENNE.

Il ne reste plus qu'à indiquer les arguments de la fonction MOYENNE.

  • Clique dans la cellule B1 pour mentionner la première cote ;
  • Frappe le signe ; pour séparer ce premier argument du suivant ;
  • Fais de même pour la cellule B2 puis frappe le séparateur ; ;
  • Sélectionne le troisième argument en B3 et frappe Enter.

La moyenne des trois cotes est automatiquement calculée. Si l'on modifie l'une des cotes, la moyenne est automatiquement ajustée.
La formule s'écrit =MOYENNE(B1;B2;B3).

Bien, votre système. Mais je n'ai pas que trois cotes à comptabiliser, moi! J'ai 12 cours différents cette année. Alors, 12 fois "cliquer - point-virgule, cliquer - point virgule, ...". Je sens que je fatigue déjà.

La solution est toute simple : il suffit de désigner en une fois la zone complète contenant les cotes à prendre en compte dans le calcul.

  • Frapper le signe = ;
  • Sélectionner la fonction MOYENNE ;
  • Sélectionner la zone contenant les données par un cliquer/glisser de la souris ;
  • Frapper Enter.
Dans ce cas, la fonction MOYENNE utilise pour argument la référence de la zone : B1:B3.

Moyenne avec nom de zone Dites, il me vient une idée là, comme ça... Les noms de zones que nous avons étudiés dans le chapitre précédent... Ce ne serait pas l'occasion de les utiliser ?

Qu'il est agréable d'avoir un élève aussi intuitif. Bien sûr, il suffit de donner un nom à la zone puis de fournir ce nom de zone pour argument à la fonction.

Donc, si nous ressuscitons " Fifi " et que nous donnons ce nom à la zone contenant les cotes, on peut écrire =MOYENNE(Fifi).

Très exactement. Elle n'est pas belle, la vie ?

La syntaxe pour l'usage d'une fonction est donc :

  • un signe = pour annoncer un calcul,
  • le nom de la fonction 
  • suivi d'une paire de parenthèses ( )
  • contenant le ou les arguments de la fonction
  • séparés par le signe ; .

Quand tu es capable d'utiliser la fonction Moyenne avec les paramètres séparés ou groupés en zone, passe à la page suivante. Vers la page suivante Page suivante


Dernière modification 03/09/2017 Test dans /info ...