L'alternative dans le tableur LibreOffice Calc

Où l'on apprend à l'ordinateur à faire ses devoirs de maths

Énoncé du problème et analyse

On demande de programmer le tableur de manière à lui faire résoudre les équations du premier degré du type ax + b = 0 d'inconnue x.

Ce type de problème est élémentaire au cours de mathématiques : il se résout de la manière suivante.

arbre binaireIl y a ici une situation d'alternative double:

  1. Il y a un choix entre deux possibilités; pour choisir, il faut examiner le coefficient de x (il est nul ou il ne l'est pas).
  2. Si adifférent0, il y a encore un choix entre deux possibilitésé; pour choisir, il faut examiner le 2ème membre de cette équation (il est nul ou il ne l'est pas).

Résultat attendu et méthode

On attend d'obtenir une feuille de calcul semblable aux exemples ci-dessous.

exemple 1

exemple 2

exemple 3

Pour la facilité, il serait souhaitable de nommer les deux cellules grisées a et b.

Alternative dans le tableur

Avant d'écrire le formalisme propre au tableur, nous présenterons l'alternative selon la forme

si <expression logique> alors <action1> sinon <action2>

Si (a<>0)
Alors
écrire (-b/a)
Sinon
Si (b<>0)
Alors écrire "Impossible"
Sinon écrire "Indéterminé"
Fin Si
Fin Si

La fonction alternative sécrira doncé:

=SI(a<>0;-b/a;SI(b<>0;"Impossible";"Indéterminé"))

ou, si l'on utilise les coordonnées plutôt que les noms

=SI(A2<>0;-D2/A2;SI(D2<>0;"Impossible";"Indéterminé"))

Utilise toutes les informations données plus haut pour résoudre le problème de la résolution des équations du premier degré avec le tableur.

Quand ta feuille de calcul est prête, teste tous les cas possibles. Ensuite, montre ton travail au professeur avant de passer à la page suivante. Vers la page suivante Page suivante


Dernière modification 18/08/2016 Test dans /info ...