L'alternative dans le tableur LibreOffice Calc

Les années bissextiles, en pratique

La pratique pose deux problèmes:

  1. il faut être capable de déterminer si un nombre est multiple d'un autre;
  2. il faut être capable d'écrire une alternative complexe.

Pour savoir si un nombre est divisible par un autre, il suffit de faire la division et de déterminer la valeur du reste de cette division. Les programmes tableurs mettent généralement une fonction MOD à la disposition des utilisateurs.

Dans la cellule frappe Résultat
A1 =MOD(27;5) 2, le reste de la division de 27 par 5
A2 12
A3 =MOD(A2;A1) 0, la division de A2 par A1 a un résultat entier !

Si la cellule qui contient le millésime de l'année est nommée "AN", l'alternative s'écrira alors:

Si MOD(AN;4)=0
Alors
Si MOD(AN;100)=0
Alors
Si MOD(AN;400)=0
Alors "Bissextile"
Sinon "Non Bissextile"
Fin Si
Sinon
"Bissextile"
Fin Si
Sinon
"Non bissextile"
Fin Si

Ce qui s'écrira simplement:

=SI(MOD(AN;4)=0;SI(MOD(AN;100)=0;SI(MOD(AN;400)=0;"Bissextile";"Non bissextile");"Bissextile");"Non bissextile")

dans le formalisme propre au tableur.

"Ce qui s'écrira simplement...". Vous en avez de bonnes, vous! Vous trouvez ça simple?

Bon, en fait, pas du tout. Et la complexité de la formule finale justifie tous les efforts de simplification et de reformulation que nous avons dû entreprendre. Sinon, impossible d'écrire cette formule.

Quand tu as compris la formule pour déterminer les dates bissextiles dans le tableur, passe à la page suivante. Vers la page suivante Page suivante


Dernière modification 18/08/2016 Test dans /info ...